Client Central Functionality

Incident Report for Yardi Systems

Resolved

The issue affecting Client Central service requests is resolved. Thank you for your patience.

The Yardi Team
Posted May 11, 2026 - 17:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 11, 2026 - 17:30 UTC

Investigating

We are investigating an issue that is affecting Client Central's ability to create service requests.
Posted May 11, 2026 - 17:27 UTC
This incident affected: Client Central.