Client Central Performance and Access issues

Incident Report for Yardi Systems

Resolved

Full functionality was confirmed as of approximately 9:10 AM PST.
Posted Mar 03, 2026 - 01:14 UTC

Identified

Today, beginning at approximately 7:20 AM PST, some Yardi users experienced performance degradation and intermittent access issues when using Client Central.

The issue was caused by a process issue that temporarily removed a subset of application servers from the load-balanced pool. The servers were restored to service, and full functionality was confirmed as of approximately 9:10 AM PST.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 03, 2026 - 01:11 UTC
This incident affected: Client Central.