RentCafe Site Manager
Incident Report for Yardi Systems
Resolved
The issue impacting RentCafe Site Manager has been resolved. Thank you for your patience.

The Yardi Team
Posted Nov 14, 2024 - 17:36 UTC
Investigating
We are investigating an issue that is impacting RentCafe Site Manager. We apologize for any inconvenience and appreciate your patience while we work through the problem.

The Yardi Team
Posted Nov 14, 2024 - 17:26 UTC
This incident affected: RentCafe (Site Manager).