Resolved
This incident has been resolved.
Posted May 01, 2026 - 19:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 18:12 UTC
Update
We are continuing to investigate this issue.
Posted May 01, 2026 - 17:14 UTC
Investigating
We are currently investigating this issue.
Posted May 01, 2026 - 17:11 UTC
This incident affected: RentCafe Middle East (API, Company Site, CMS, ILS, Property Site, Resident Services, Secure Cafe, Site Manager), RentCafe ANZ (API, CMS, ILS, Property Sites, Resident Services, Secure Cafe, Site Manager, WordPressBlogs, ChatIQ, Conversations), RentCafe (API, Call Center, Chat IQ, Conversations, ILS, Marketing & Property Websites, Online Leasing, Resident Services, SecureCafe, Service Provider, Site Manager, Social Housing, StorageCafe, CRM), and RentCafe UK (ChatIQ, Conversations, API, CMS, ILS, Marketing & Property Websites, Resident Services, Secure Cafe, Site Manager, WordPressBlogs).